aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Markgraf <steve@steve-m.de>2013-06-04 14:47:16 +0200
committerSteve Markgraf <steve@steve-m.de>2013-06-04 20:57:43 +0200
commit3e17ef2b55d80237da9766f3464ae784448a23e6 (patch)
treec76d57326e7ee9cf77815a47512aa4dabd510af0 /configure.ac
parentce341fe53bb235f1c8d848ae850ebc136b08f563 (diff)
lib: don't detach kernel driver by default
Since this feature also disconnects running instances of librtlsdr that claimed the device, it is now disabled by default and can only be enabled at compile time. To enable it when building with cmake: cmake . -DDETACH_KERNEL_DRIVER=ON To enable it when building with automake: ./configure --enable-driver-detach Signed-off-by: Steve Markgraf <steve@steve-m.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 954d2ef..ce47d89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,12 @@ AC_TRY_COMPILE([],[],
AC_MSG_RESULT(no)
CFLAGS="$old_CFLAGS")
+AC_ARG_ENABLE(driver-detach,
+[ --enable-driver-detach Enable detaching of kernel driver (disabled by default)],
+[if test x$enableval = xyes; then
+ CFLAGS="$CFLAGS -DDETACH_KERNEL_DRIVER"
+fi])
+
dnl Generate the output
AC_CONFIG_HEADER(config.h)