summaryrefslogtreecommitdiffstats
path: root/src/host/trxcon/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2017-07-26 14:30:35 +0600
committerVadim Yanitskiy <axilirator@gmail.com>2017-11-19 17:35:07 +0700
commit9760a84a6db802d8c54d239a4d76334e93bac607 (patch)
treef0899f3d08668fae2bce02a31d6561a8d362de70 /src/host/trxcon/Makefile.am
parentf604869944d594431654332b0bad59a6e7a997e4 (diff)
host/trxcon: split sched_lchan_handlers.c
It would be better to have xCCH, SCH and RACH burst handlers in separate files, because as much code we add to a single file, as harder it becomes to read and understand one. Change-Id: I456a60e68b32b792e63dd03ae97159dc101fd4bf
Diffstat (limited to 'src/host/trxcon/Makefile.am')
-rw-r--r--src/host/trxcon/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/host/trxcon/Makefile.am b/src/host/trxcon/Makefile.am
index b2f22fab..cd4bbd25 100644
--- a/src/host/trxcon/Makefile.am
+++ b/src/host/trxcon/Makefile.am
@@ -31,8 +31,10 @@ trxcon_SOURCES = \
# Scheduler
trxcon_SOURCES += \
- sched_lchan_handlers.c \
sched_lchan_desc.c \
+ sched_lchan_xcch.c \
+ sched_lchan_rach.c \
+ sched_lchan_sch.c \
sched_mframe.c \
sched_clck.c \
sched_trx.c \