aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/device/uhd/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2019-04-29 17:23:21 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2019-05-03 13:50:47 +0200
commit7bef2346c41d2e02d221a7f501a295bd5cbbbc9b (patch)
tree1d4743fb993173eb70e740babfd1aa38a422f868 /Transceiver52M/device/uhd/Makefile.am
parent2876785f5069a3b1d5c39f0a8af59fb497e5267a (diff)
cosmetic: uhd: Move smpl_buf out of UHDDevice, move UHDDevice class definition to .h
* move class definition to .h file, like we do for other devices. * move smpl_buf class to a different file inside uhd/. * Preparation work to have smpl_buf being used in a generic way for devices other than UHD (LMS). Change-Id: Ib4594320da9bb7f6e9f52e7d70d11ecd11106aae
Diffstat (limited to 'Transceiver52M/device/uhd/Makefile.am')
-rw-r--r--Transceiver52M/device/uhd/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Transceiver52M/device/uhd/Makefile.am b/Transceiver52M/device/uhd/Makefile.am
index bb34d2f..4fcc0d7 100644
--- a/Transceiver52M/device/uhd/Makefile.am
+++ b/Transceiver52M/device/uhd/Makefile.am
@@ -3,6 +3,8 @@ include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = -Wall $(STD_DEFINES_AND_INCLUDES) -I${srcdir}/..
AM_CXXFLAGS = -lpthread $(LIBOSMOCORE_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOVTY_CFLAGS) $(UHD_CFLAGS)
+noinst_HEADERS = UHDDevice.h smpl_buf.h
+
noinst_LTLIBRARIES = libdevice.la
-libdevice_la_SOURCES = UHDDevice.cpp
+libdevice_la_SOURCES = UHDDevice.cpp smpl_buf.cpp