aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2021-02-06 23:21:55 +0100
committerHarald Welte <laforge@osmocom.org>2021-02-08 18:00:56 +0100
commit943affdd48151dfeca009976dd78db79fb77ca55 (patch)
treea23bf7616ca06d3c964efbcdf0dec9aab0e6a9e0 /src/Makefile.am
parent6cb841b92bf1457dd11cba02fca25ce74836d2e5 (diff)
sccp: Notify users of point code available/unavailable
* add N-PCSTATE.ind and N-STATE.ind definitions to SCCP user SAP * add minimal SCMG (SCCP Management) and LBCS (Local Broadcast) * generate MTP-PAUSE.ind/MTP-RESUME.ind based on received xUA DUNA/DAVA * generate N-PCSTATE.ind towards the local SCCP users Change-Id: Idb799f7d7ab329ad12f07b7cbe6336da0891ae92 Related: OS#2623, OS#3403, OS#4701
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 41d2a8d..4558810 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -29,7 +29,8 @@ LIBVERSION=5:0:0
libosmo_sigtran_la_SOURCES = sccp_sap.c sua.c m3ua.c xua_msg.c sccp_helpers.c \
sccp2sua.c sccp_scrc.c sccp_sclc.c sccp_scoc.c \
- sccp_user.c sccp_types.c xua_rkm.c xua_shared.c xua_default_lm_fsm.c \
+ sccp_user.c sccp_types.c sccp_lbcs.c sccp_scmg.c \
+ xua_rkm.c xua_shared.c xua_default_lm_fsm.c \
osmo_ss7.c osmo_ss7_hmrt.c xua_asp_fsm.c xua_as_fsm.c \
xua_snm.c osmo_ss7_vty.c sccp_vty.c ipa.c
libosmo_sigtran_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined -export-symbols-regex '^osmo_'