aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2021-02-06 21:39:12 +0100
committerHarald Welte <laforge@osmocom.org>2021-02-08 18:00:56 +0100
commit6cb841b92bf1457dd11cba02fca25ce74836d2e5 (patch)
tree8d2000de8e57eaf6c550d2f48af5e7967079c7b1 /src/Makefile.am
parentf5d90c46e15dd79776d9b760ed5854e7ff94cdaa (diff)
xua: Implement SNM availability/unavailability messaging
M3UA and SUA have one sub-protocol called [S]SNM, through which the SG informs the ASP about certain destinations (point codes) becoming available (DAVA) or unavailable (DUNA) in the SS7 network. This patch adds support for * generating DAVA/DUAN on a SGP when the AS FSM changes to/from AS-ACTIVE * receiving DAVA/DUNA on an ASP and informing other "SG role" AS/ASP * processing DAUD from ASP received by SG, generating relate DAVA/DUNA responses Related: OS#2623 Change-Id: Id92be4691b0fd77598a6edb642c028bbd8c5b623
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 91084de..41d2a8d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -31,7 +31,7 @@ libosmo_sigtran_la_SOURCES = sccp_sap.c sua.c m3ua.c xua_msg.c sccp_helpers.c \
sccp2sua.c sccp_scrc.c sccp_sclc.c sccp_scoc.c \
sccp_user.c sccp_types.c xua_rkm.c xua_shared.c xua_default_lm_fsm.c \
osmo_ss7.c osmo_ss7_hmrt.c xua_asp_fsm.c xua_as_fsm.c \
- osmo_ss7_vty.c sccp_vty.c ipa.c
+ xua_snm.c osmo_ss7_vty.c sccp_vty.c ipa.c
libosmo_sigtran_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined -export-symbols-regex '^osmo_'
libosmo_sigtran_la_LIBADD = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) \
$(LIBOSMONETIF_LIBS) $(LIBSCTP_LIBS)