aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/transum/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/transum/Makefile.am')
-rw-r--r--plugins/transum/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/plugins/transum/Makefile.am b/plugins/transum/Makefile.am
index d2910c695e..05b3dfcdd3 100644
--- a/plugins/transum/Makefile.am
+++ b/plugins/transum/Makefile.am
@@ -24,6 +24,9 @@ include ../Makefile.am.inc
# the name of the plugin
PLUGIN_NAME = transum
+BUILT_SOURCES = \
+ plugin.c
+
# Non-generated sources to be scanned for registration routines
NONGENERATED_REGISTER_C_FILES = \
packet-transum.c
@@ -47,11 +50,13 @@ HEADER_FILES = \
plugin_LTLIBRARIES = transum.la
transum_la_SOURCES = \
- plugin.c \
moduleinfo.h \
$(SRC_FILES) \
$(HEADER_FILES)
+nodist_transum_la_SOURCES = \
+ plugin.c
+
transum_la_CPPFLAGS = $(AM_CPPFLAGS) $(PLUGIN_CPPFLAGS)
transum_la_CFLAGS = $(AM_CFLAGS) $(PLUGIN_CFLAGS)