aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/transum/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-18 23:37:49 +0100
committerJoão Valverde <j@v6e.pt>2017-10-20 04:37:16 +0000
commite6e8b7b662419466a264201a6d08af2dc9a737e9 (patch)
treea4fbb48640dacaeaca3926ff7470a211d24b37d4 /plugins/transum/Makefile.am
parentd64c300522ffa830e061adeb81e75255b3f955ac (diff)
autotools: Sort out how we handle plugin.c
Change-Id: Ie9570a63a1479021753807f76dd5e98fbbec7b86 Reviewed-on: https://code.wireshark.org/review/23995 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'plugins/transum/Makefile.am')
-rw-r--r--plugins/transum/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/plugins/transum/Makefile.am b/plugins/transum/Makefile.am
index d2910c695e..05b3dfcdd3 100644
--- a/plugins/transum/Makefile.am
+++ b/plugins/transum/Makefile.am
@@ -24,6 +24,9 @@ include ../Makefile.am.inc
# the name of the plugin
PLUGIN_NAME = transum
+BUILT_SOURCES = \
+ plugin.c
+
# Non-generated sources to be scanned for registration routines
NONGENERATED_REGISTER_C_FILES = \
packet-transum.c
@@ -47,11 +50,13 @@ HEADER_FILES = \
plugin_LTLIBRARIES = transum.la
transum_la_SOURCES = \
- plugin.c \
moduleinfo.h \
$(SRC_FILES) \
$(HEADER_FILES)
+nodist_transum_la_SOURCES = \
+ plugin.c
+
transum_la_CPPFLAGS = $(AM_CPPFLAGS) $(PLUGIN_CPPFLAGS)
transum_la_CFLAGS = $(AM_CFLAGS) $(PLUGIN_CFLAGS)