aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index de9477378c..166f3653ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1601,10 +1601,19 @@ if test "x$enable_wireshark" = "xyes"; then
"x$with_gtk3" = "xunspecified" -a \
"x$with_qt" = "xunspecified"; then
#
- # No GUI toolkit was explicitly specified; pick Qt and GTK+ 3.
+ # No GUI toolkits were explicitly specified; pick Qt
+ # and GTK+ 3.
#
with_qt=yes
with_gtk3=yes
+ elif test "x$with_gtk2" = "xunspecified" -a \
+ "x$with_gtk3" = "xunspecified" -a \
+ "x$with_qt" = "xno"; then
+ #
+ # Qt was explicitly disabled, and neither GTK+ 2 nor
+ # GTK+ 3 were explicitly specified; pick GTK+ 3.
+ #
+ with_gtk3=yes
fi
if test "x$with_qt" != "xno"; then
#