aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2015-05-05 22:37:25 -0700
committerGuy Harris <guy@alum.mit.edu>2015-05-06 05:38:25 +0000
commit2cf2f36fb3cc2c114c8ba1220f345f10e458fb87 (patch)
tree5a9ee29efa0eab3578096858a2ac6175d9887780 /configure.ac
parentb5ef92efc067eb172ab71cc39b0aa3f32ab5f01d (diff)
Fix configuration with --without-qt and with no --with-gtk[23].
If building with Wireshark wasn't explicitly disabled - i.e., if we are building Wireshark, which means we are building an application with a GUI - and Qt was explicitly disabled, and neither GTK+ 2 nor GTK+ 3 were explicitly enabled, look for GTK+ 3. Change-Id: Ib913355f7b483d065e766605aa88a71fa9984f36 Reviewed-on: https://code.wireshark.org/review/8306 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index de9477378c..166f3653ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1601,10 +1601,19 @@ if test "x$enable_wireshark" = "xyes"; then
"x$with_gtk3" = "xunspecified" -a \
"x$with_qt" = "xunspecified"; then
#
- # No GUI toolkit was explicitly specified; pick Qt and GTK+ 3.
+ # No GUI toolkits were explicitly specified; pick Qt
+ # and GTK+ 3.
#
with_qt=yes
with_gtk3=yes
+ elif test "x$with_gtk2" = "xunspecified" -a \
+ "x$with_gtk3" = "xunspecified" -a \
+ "x$with_qt" = "xno"; then
+ #
+ # Qt was explicitly disabled, and neither GTK+ 2 nor
+ # GTK+ 3 were explicitly specified; pick GTK+ 3.
+ #
+ with_gtk3=yes
fi
if test "x$with_qt" != "xno"; then
#