aboutsummaryrefslogtreecommitdiffstats
path: root/epan/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2007-05-25 23:40:42 +0000
committerGerald Combs <gerald@wireshark.org>2007-05-25 23:40:42 +0000
commita491fec183044f6065b8d92a3775f5130049b636 (patch)
tree3f899da6a2bb6dead6dbfa2392764a88ac26faa6 /epan/Makefile.am
parent1e7c1bc0369f0c962ed73e8e34fa5ba7fa1a6c3d (diff)
From Mike Harvey: Support for WiMAX and the WiMAX M2M encapsulation protocol.
Add support for WiMAX and M2M to various makefiles and installer files. Add basic support for M2M to randpkt. svn path=/trunk/; revision=21945
Diffstat (limited to 'epan/Makefile.am')
-rw-r--r--epan/Makefile.am47
1 files changed, 46 insertions, 1 deletions
diff --git a/epan/Makefile.am b/epan/Makefile.am
index 200a300767..e48254c819 100644
--- a/epan/Makefile.am
+++ b/epan/Makefile.am
@@ -189,11 +189,56 @@ plugin_src = \
../plugins/gryphon/packet-gryphon.c \
../plugins/irda/packet-irda.c \
../plugins/lwres/packet-lwres.c \
+ ../plugins/m2m/packet-m2m.c \
+ ../plugins/m2m/wimax_tlv.c \
../plugins/mgcp/packet-mgcp.c \
../plugins/pcli/packet-pcli.c \
../plugins/rdm/packet-rdm.c \
../plugins/rtnet/packet-rtnet.c \
- ../plugins/v5ua/packet-v5ua.c
+ ../plugins/v5ua/packet-v5ua.c \
+ ../plugins/wimax/crc.c \
+ ../plugins/wimax/crc_data.c \
+ ../plugins/wimax/mac_hd_generic_decoder.c \
+ ../plugins/wimax/mac_hd_type1_decoder.c \
+ ../plugins/wimax/mac_hd_type2_decoder.c \
+ ../plugins/wimax/mac_mgmt_msg_decoder.c \
+ ../plugins/wimax/msg_aas_beam.c \
+ ../plugins/wimax/msg_aas_fbck.c \
+ ../plugins/wimax/msg_arq.c \
+ ../plugins/wimax/msg_clk_cmp.c \
+ ../plugins/wimax/msg_dcd.c \
+ ../plugins/wimax/msg_dlmap.c \
+ ../plugins/wimax/msg_dreg.c \
+ ../plugins/wimax/msg_dsa.c \
+ ../plugins/wimax/msg_dsc.c \
+ ../plugins/wimax/msg_dsd.c \
+ ../plugins/wimax/msg_dsx_rvd.c \
+ ../plugins/wimax/msg_fpc.c \
+ ../plugins/wimax/msg_pkm.c \
+ ../plugins/wimax/msg_pmc.c \
+ ../plugins/wimax/msg_prc_lt_ctrl.c \
+ ../plugins/wimax/msg_reg_req.c \
+ ../plugins/wimax/msg_reg_rsp.c \
+ ../plugins/wimax/msg_rep.c \
+ ../plugins/wimax/msg_res_cmd.c \
+ ../plugins/wimax/msg_rng_req.c \
+ ../plugins/wimax/msg_rng_rsp.c \
+ ../plugins/wimax/msg_sbc.c \
+ ../plugins/wimax/msg_ucd.c \
+ ../plugins/wimax/msg_ulmap.c \
+ ../plugins/wimax/packet-wmx.c \
+ ../plugins/wimax/wimax_cdma_code_decoder.c \
+ ../plugins/wimax/wimax_compact_dlmap_ie_decoder.c \
+ ../plugins/wimax/wimax_compact_ulmap_ie_decoder.c \
+ ../plugins/wimax/wimax_fch_decoder.c \
+ ../plugins/wimax/wimax_ffb_decoder.c \
+ ../plugins/wimax/wimax_hack_decoder.c \
+ ../plugins/wimax/wimax_harq_map_decoder.c \
+ ../plugins/wimax/wimax_pdu_decoder.c \
+ ../plugins/wimax/wimax_phy_attributes_decoder.c \
+ ../plugins/wimax/wimax_tlv.c \
+ ../plugins/wimax/wimax_utils.c
+
else # ENABLE_STATIC