aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2018-12-06 21:31:01 +0100
committerJaap Keuter <jaap.keuter@xs4all.nl>2018-12-06 23:22:52 +0000
commitceef87c5507388a789af18366b896a88c4a9861b (patch)
tree0d59f5811092b83649ced436b52145d5a30fd29f /CMakeLists.txt
parent247e729d9e4262fbcd6af8fafd474eb1af480d2a (diff)
CMake: limit -Wextra-semi to C++ only
Saves a check and removes a GCC warning from CMakeError.log: cc1: warning: command line option ‘-Wextra-semi’ is valid for C++/ObjC++ but not for C Change-Id: I76d027e7b5703b06237ac70eb340c4a09322e09e Fixes: v2.9.0rc0-958-g866ddb1b18 ("Add -Wextra-semi to (clang) C and C++ flags to make sure the buildbots will find this.") Reviewed-on: https://code.wireshark.org/review/30948 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt> Reviewed-by: Jaap Keuter <jaap.keuter@xs4all.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 352de03696..0cbca5c297 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -563,7 +563,6 @@ else() # ! MSVC
# -O<X> and -g get set by the CMAKE_BUILD_TYPE
-Wall
-Wextra
- -Wextra-semi
-Wendif-labels
-Wpointer-arith
-Wformat-security
@@ -641,6 +640,7 @@ else() # ! MSVC
list(APPEND WIRESHARK_CXX_ONLY_FLAGS
+ -Wextra-semi
)
#