aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDario Lombardo <lomato@gmail.com>2019-01-06 10:34:32 +0100
committerPeter Wu <peter@lekensteyn.nl>2019-01-14 16:00:29 +0000
commitc3d198c401d5ec17289159cc88e2f891070e7779 (patch)
treefee286134f8799ecc84211baf6099ab204876338 /CMakeLists.txt
parent252938ed253846671a101f6b3f3e90354be3e4b2 (diff)
dfilter: add string() function.
This function can convert non-string fields into strings. This allows the user to apply string functions (like contains and matches) to non-string fields. Examples: string(frame.number) matches "[13579]$" => for odd frames string(eth.dst) matches "aa\.bb\.cc\.dd\.ee\..." => to match a group of stations string(snmp.name) matches "^1.2.3.4" => for all OIDs under a specific node Change-Id: I18173f50ba5314ecdcd1e4b66c7e8ba5b44257ee Reviewed-on: https://code.wireshark.org/review/31427 Petri-Dish: Peter Wu <peter@lekensteyn.nl> Tested-by: Petri Dish Buildbot Reviewed-by: Peter Wu <peter@lekensteyn.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f0853b9744..5f74e5f957 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3131,6 +3131,7 @@ set(_test_group_list
suite_dfilter.group_bytes_ipv6
suite_dfilter.group_bytes_type
suite_dfilter.group_double
+ suite_dfilter.group_dfunction_string
suite_dfilter.group_integer
suite_dfilter.group_integer_1byte
suite_dfilter.group_ipv4