aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2019-01-14 13:26:14 +0100
committerAnders Broman <a.broman58@gmail.com>2019-01-14 15:21:45 +0000
commit252938ed253846671a101f6b3f3e90354be3e4b2 (patch)
treea972ec92b55618dddac169ccfc58389f98b8a1e8 /CMakeLists.txt
parentd38f6025b08b66b0a5ae96bf79eb78a28ca04896 (diff)
CMake: remove --clean from rpmbuild invocation
This allows for inspection of the build artifacts for a RPM build. It is consistent with the deb-package target not executing --post-clean. Change-Id: I63e3c571c893a104b5cfa98a0c67c8fdca03a964 Reviewed-on: https://code.wireshark.org/review/31538 Reviewed-by: Peter Wu <peter@lekensteyn.nl> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95dac86105..f0853b9744 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2861,7 +2861,7 @@ if(RPMBUILD_EXECUTABLE)
--define "_topdir ${CMAKE_BINARY_DIR}/packaging/rpm"
--define "_prefix ${CMAKE_INSTALL_PREFIX}"
${_rpmbuild_with_args}
- --clean -ba SPECS/wireshark.spec
+ -ba SPECS/wireshark.spec
DEPENDS "${CMAKE_BINARY_DIR}/packaging/rpm/SOURCES/${_export_tarball}"
WORKING_DIRECTORY "${CMAKE_BINARY_DIR}/packaging/rpm"
COMMENT "Create a tarball from the current git commit."