aboutsummaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2017-02-18 13:51:26 +0100
committerAndreas Eversberg <jolly@eversberg.eu>2017-02-18 21:02:55 +0100
commit438ce08add20e8c5daa0377273a84e868844a6b5 (patch)
tree77d88aaf1f3b222bf4b502910484deef88cd5650 /src/test/Makefile.am
parent17b61241224631142ffb5e560ae527b853996bba (diff)
SoapySDR support
There is no time stamp handling. It is just TX'ing in advance and synchronous to received RX rate.
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index eb50f7d..393a0b5 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -16,6 +16,7 @@ test_filter_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_compandor_SOURCES = test_compandor.c
@@ -32,6 +33,7 @@ test_emphasis_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_dms_SOURCES = \
@@ -44,6 +46,7 @@ test_dms_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_sms_SOURCES = \
@@ -56,6 +59,7 @@ test_sms_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_performance_SOURCES = dummy.c test_performance.c
@@ -65,5 +69,6 @@ test_performance_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm