aboutsummaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index eb50f7d..393a0b5 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -16,6 +16,7 @@ test_filter_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_compandor_SOURCES = test_compandor.c
@@ -32,6 +33,7 @@ test_emphasis_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_dms_SOURCES = \
@@ -44,6 +46,7 @@ test_dms_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_sms_SOURCES = \
@@ -56,6 +59,7 @@ test_sms_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm
test_performance_SOURCES = dummy.c test_performance.c
@@ -65,5 +69,6 @@ test_performance_LDADD = \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
$(UHD_LIBS) \
+ $(SOAPY_LIBS) \
-lm