aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2022-11-29 22:33:54 +0100
committerHarald Welte <laforge@gnumonks.org>2023-01-21 22:41:57 +0100
commitd55a209d1c1eaf48d11d851c6a5082af7df36d69 (patch)
treef6395ad8e875a619354e9687951af086b5e3cee1 /configure.ac
parent88955fb5506280a82860b026f8d7db9ad57bb504 (diff)
create libosmoisdn sub-library
There are some parts of libosmogsm which are not really GSM specific, but rather ISDN bits that were inherited by GSM. This includes the I.460 multiplex as well as the core LAPD protocol. Let's move those bits to its own libosmoisdn library, before we add more ISDN specific bits to the wrong place. Backwards-compatibility is created by making libosmogsm depend on libosmoisdn, and by providing wrapper include files for source compatibility. Change-Id: Ib1a6c762322fd5047be3188b1df22408ef06aa50
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9c9681d8..1a87ec19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -53,12 +53,14 @@ case $host in
*)
LTLDFLAGS_OSMOGB='-Wl,--version-script=$(srcdir)/libosmogb.map'
LTLDFLAGS_OSMOGSM='-Wl,--version-script=$(srcdir)/libosmogsm.map'
+ LTLDFLAGS_OSMOISDN='-Wl,--version-script=$(srcdir)/libosmoisdn.map'
LTLDFLAGS_OSMOCODING='-Wl,--version-script=$(srcdir)/libosmocoding.map'
LTLDFLAGS_OSMOCTRL='-Wl,--version-script=$(srcdir)/libosmoctrl.map'
;;
esac
AC_SUBST(LTLDFLAGS_OSMOGB)
AC_SUBST(LTLDFLAGS_OSMOGSM)
+AC_SUBST(LTLDFLAGS_OSMOISDN)
AC_SUBST(LTLDFLAGS_OSMOCODING)
AC_SUBST(LTLDFLAGS_OSMOCTRL)
@@ -580,6 +582,7 @@ AC_OUTPUT(
libosmocoding.pc
libosmovty.pc
libosmogsm.pc
+ libosmoisdn.pc
libosmogb.pc
libosmoctrl.pc
libosmosim.pc
@@ -595,6 +598,7 @@ AC_OUTPUT(
include/osmocom/gprs/protocol/Makefile
include/osmocom/gsm/Makefile
include/osmocom/gsm/protocol/Makefile
+ include/osmocom/isdn/Makefile
include/osmocom/sim/Makefile
include/osmocom/usb/Makefile
include/osmocom/vty/Makefile
@@ -606,6 +610,7 @@ AC_OUTPUT(
src/sim/Makefile
src/usb/Makefile
src/gsm/Makefile
+ src/isdn/Makefile
src/gb/Makefile
src/ctrl/Makefile
src/pseudotalloc/Makefile
@@ -616,6 +621,7 @@ AC_OUTPUT(
utils/osmo-stat-dummy/Makefile
Doxyfile.core
Doxyfile.gsm
+ Doxyfile.isdn
Doxyfile.vty
Doxyfile.codec
Doxyfile.coding