aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2016-12-21 14:18:34 +0100
committerPhilipp <pmaier@sysmocom.de>2016-12-22 18:22:25 +0100
commit0f333f4174fd3ed269aafaced1dd31b96214e509 (patch)
tree40b0fefa267cccf77709a752ad7bb7edffb68216 /debian/rules
parentbdb67a70da86f720bc7f53731d156cf8b080be7f (diff)
Integrate Debian packaging changes
debian/control: * restructure to make it easier to incorporate further changes * update package descriptions * update project URL debian/rules: * use proper hardening syntax * restructure to make it easier to incorporate further changes * add cleanup override debian/copyright: add file matching Debian format Change-Id: I6af8ab7f5c75b4d161cebf492f3de5d9dbd00220 Related: OS#1694
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d3f1534..cec3c9f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,9 @@ DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
+
%:
dh $@ --with autoreconf --fail-missing
@@ -16,3 +17,7 @@ override_dh_strip:
override_dh_autoreconf:
echo $(VERSION) > .tarball-version
dh_autoreconf
+
+override_dh_clean:
+ dh_clean
+ rm -f tests/package.m4 tests/testsuite .version .tarball-version