aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index d3f1534..cec3c9f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,8 +4,9 @@ DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
#export DH_VERBOSE=1
-export DEB_BUILD_HARDENING=1
+
%:
dh $@ --with autoreconf --fail-missing
@@ -16,3 +17,7 @@ override_dh_strip:
override_dh_autoreconf:
echo $(VERSION) > .tarball-version
dh_autoreconf
+
+override_dh_clean:
+ dh_clean
+ rm -f tests/package.m4 tests/testsuite .version .tarball-version