aboutsummaryrefslogtreecommitdiffstats
path: root/lib/rtl_tcp/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Stolnikov <horizon@noreply.osmocom.org>2023-12-03 09:08:40 +0000
committerDimitri Stolnikov <horizon@noreply.osmocom.org>2023-12-03 09:08:40 +0000
commit73d8982ac0d1f05461d49c379bb45f018c5f32f2 (patch)
treeb4df92a78327af937eedc36a9f7b0093721b2cd6 /lib/rtl_tcp/CMakeLists.txt
parent48422c87a992a862358ef8115ccaaf93bfc1336a (diff)
parent14d411617571b9e34f0d89c011ca2e668763deab (diff)
Merge pull request 'Fix compilation of retpitaya and rtl_tcp with MinGW' (#5) from argilo/gr-osmosdr:fix-win-compile into masterv0.2.5
Reviewed-on: https://gitea.osmocom.org/sdr/gr-osmosdr/pulls/5
Diffstat (limited to 'lib/rtl_tcp/CMakeLists.txt')
-rw-r--r--lib/rtl_tcp/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/rtl_tcp/CMakeLists.txt b/lib/rtl_tcp/CMakeLists.txt
index 2de6cee..e5477d9 100644
--- a/lib/rtl_tcp/CMakeLists.txt
+++ b/lib/rtl_tcp/CMakeLists.txt
@@ -29,6 +29,12 @@ APPEND_LIB_LIST(
${Gnuradio-blocks_LIBRARIES}
)
+if(WIN32)
+ APPEND_LIB_LIST(
+ ws2_32
+ )
+endif()
+
list(APPEND gr_osmosdr_srcs
${CMAKE_CURRENT_SOURCE_DIR}/rtl_tcp_source_c.cc
)