summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8c5ff1c..f8cfc80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,11 +76,11 @@ AC_C_CONST
AC_C_INLINE
PKG_CHECK_MODULES([CHECK], [check >= 0.9.0],
- [AC_DEFINE([ENABLE_UNIT_TESTS], [1], [Do unit tests])],
+ [enable_unit_tests="yes"],
[AC_MSG_WARN([*** Disabling building of unit tests])
- AC_DEFINE([ENABLE_UNIT_TESTS], [0], [Do not do unit tests])])
+ enable_unit_tests="no"])
-AM_CONDITIONAL([ENABLE_UNIT_TESTS], [test "x$ENABLE_UNIT_TESTS" = "xyes"])
+AM_CONDITIONAL([ENABLE_UNIT_TESTS], [test "$enable_unit_tests" = "yes"])
AC_ARG_WITH([pkgconfigdir], AS_HELP_STRING([--with-pkgconfigdir=PATH],
[Path to the pkgconfig directory [[LIBDIR/pkgconfig]]]),