summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2013-04-28 11:41:15 +0200
committerThomas Graf <tgraf@suug.ch>2013-04-28 11:41:15 +0200
commitffc0ee35405cc43b26575359ef09775bce4533ba (patch)
treee61a951dc6ce09a40756f7842fa479fcbc368ff5 /configure.ac
parent979ea335b0141eb62682056be42ccb4b01e6e2a2 (diff)
configure: Convert ENABLE_UNIT_TESTS to a mere AM conditional
Signed-off-by: Thomas Graf <tgraf@suug.ch>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8c5ff1c..f8cfc80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,11 +76,11 @@ AC_C_CONST
AC_C_INLINE
PKG_CHECK_MODULES([CHECK], [check >= 0.9.0],
- [AC_DEFINE([ENABLE_UNIT_TESTS], [1], [Do unit tests])],
+ [enable_unit_tests="yes"],
[AC_MSG_WARN([*** Disabling building of unit tests])
- AC_DEFINE([ENABLE_UNIT_TESTS], [0], [Do not do unit tests])])
+ enable_unit_tests="no"])
-AM_CONDITIONAL([ENABLE_UNIT_TESTS], [test "x$ENABLE_UNIT_TESTS" = "xyes"])
+AM_CONDITIONAL([ENABLE_UNIT_TESTS], [test "$enable_unit_tests" = "yes"])
AC_ARG_WITH([pkgconfigdir], AS_HELP_STRING([--with-pkgconfigdir=PATH],
[Path to the pkgconfig directory [[LIBDIR/pkgconfig]]]),