aboutsummaryrefslogtreecommitdiffstats
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 9eaf949525..dfdd214228 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -132,13 +132,22 @@ pipe_icon.h:
echo >> $@
gdk-pixbuf-csource --raw --name=pipe_pb_data $(top_srcdir)/image/toolbar/pipe_16.png >> $@
+TOOLBAR_COMMON_ICONS = \
+ capture_interfaces \
+ capture_options \
+ capture_restart \
+ capture_start \
+ capture_stop \
+ gnome_emblem_web \
+ toolbar_wireshark_file
+
toolbar_icons.h:
echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
echo >> $@
- for icon16 in gnome_emblem_web toolbar_wireshark_file capture_options capture_restart capture_start capture_stop ; do \
+ for icon16 in $(TOOLBAR_COMMON_ICONS) ; do \
gdk-pixbuf-csource --raw --name=$${icon16}_16_pb_data $(top_srcdir)/image/toolbar/$${icon16}_16.png >> $@ ;\
done
- for icon24 in gnome_emblem_web toolbar_wireshark_file capture_options capture_restart capture_start capture_stop ; do \
+ for icon24 in $(TOOLBAR_COMMON_ICONS) ; do \
gdk-pixbuf-csource --raw --name=$${icon24}_24_pb_data $(top_srcdir)/image/toolbar/$${icon24}_24.png >> $@ ;\
done