aboutsummaryrefslogtreecommitdiffstats
path: root/tools/pidl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'tools/pidl/Makefile.PL')
-rwxr-xr-xtools/pidl/Makefile.PL25
1 files changed, 0 insertions, 25 deletions
diff --git a/tools/pidl/Makefile.PL b/tools/pidl/Makefile.PL
deleted file mode 100755
index fa250cabc3..0000000000
--- a/tools/pidl/Makefile.PL
+++ /dev/null
@@ -1,25 +0,0 @@
-use ExtUtils::MakeMaker;
-WriteMakefile(
- 'NAME' => 'Parse::Pidl',
- 'VERSION_FROM' => 'lib/Parse/Pidl.pm',
- 'EXE_FILES' => [ 'pidl' ],
- 'PMLIBDIRS' => [ 'lib' ],
- 'test' => { 'TESTS' => 'tests/*.pl' }
-);
-
-sub MY::postamble {
-<<'EOT';
-lib/Parse/Pidl/IDL.pm :: idl.yp
- yapp -s -m 'Parse::Pidl::IDL' -o 'lib/Parse/Pidl/IDL.pm' idl.yp
-
-doc: pidl.1 pidl.1.html
-
-XSLTPROC=xsltproc
-
-%.1: %.1.xml
- test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl $<
-
-%.html: %.xml
- test -z "$(XSLTPROC)" || $(XSLTPROC) -o $@ http://docbook.sourceforge.net/release/xsl/current/html/docbook.xsl $<
-EOT
-}