aboutsummaryrefslogtreecommitdiffstats
path: root/randpkt_core/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'randpkt_core/CMakeLists.txt')
-rw-r--r--randpkt_core/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/randpkt_core/CMakeLists.txt b/randpkt_core/CMakeLists.txt
index 7f17f3dc37..61c50f47f9 100644
--- a/randpkt_core/CMakeLists.txt
+++ b/randpkt_core/CMakeLists.txt
@@ -27,12 +27,16 @@ add_library(randpkt_core STATIC
set_target_properties(randpkt_core PROPERTIES
LINK_FLAGS "${WS_LINK_FLAGS}"
FOLDER "Libs")
+if(MSVC)
+ set_target_properties(randpkt_core PROPERTIES LINK_FLAGS_DEBUG "${WS_MSVC_DEBUG_LINK_FLAGS}")
+endif()
+
+target_link_libraries(randpkt_core PUBLIC ui)
CHECKAPI(
NAME
randpkt_core-base
SWITCHES
- -g deprecated-gtk
SOURCES
${RANDPKT_CORE_SRC}
${RANDPKT_CORE_HEADERS}
@@ -41,14 +45,14 @@ CHECKAPI(
NAME
randpkt_core-todo
SWITCHES
- -M -g deprecated-gtk-todo
+ -M
SOURCES
${RANDPKT_CORE_SRC}
${RANDPKT_CORE_HEADERS}
)
#
-# Editor modelines - http://www.wireshark.org/tools/modelines.html
+# Editor modelines - https://www.wireshark.org/tools/modelines.html
#
# Local variables:
# c-basic-offset: 8