aboutsummaryrefslogtreecommitdiffstats
path: root/plugins/irda/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/irda/CMakeLists.txt')
-rw-r--r--plugins/irda/CMakeLists.txt25
1 files changed, 18 insertions, 7 deletions
diff --git a/plugins/irda/CMakeLists.txt b/plugins/irda/CMakeLists.txt
index d035ab05d4..f0e75ae7ea 100644
--- a/plugins/irda/CMakeLists.txt
+++ b/plugins/irda/CMakeLists.txt
@@ -39,13 +39,11 @@ set(CLEAN_FILES
${PLUGIN_FILES}
)
-if (WERROR_COMMON_FLAGS)
- set_source_files_properties(
- ${CLEAN_FILES}
- PROPERTIES
- COMPILE_FLAGS ${WERROR_COMMON_FLAGS}
- )
-endif()
+set_source_files_properties(
+ ${CLEAN_FILES}
+ PROPERTIES
+ COMPILE_FLAGS "${WERROR_COMMON_FLAGS}"
+)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})
@@ -72,3 +70,16 @@ CHECKAPI(
${DISSECTOR_SRC}
${DISSECTOR_HEADERS}
)
+
+#
+# Editor modelines - http://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#