aboutsummaryrefslogtreecommitdiffstats
path: root/epan/dfilter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'epan/dfilter/Makefile.am')
-rw-r--r--epan/dfilter/Makefile.am24
1 files changed, 7 insertions, 17 deletions
diff --git a/epan/dfilter/Makefile.am b/epan/dfilter/Makefile.am
index 7db0fa2b46..b89c44cc8c 100644
--- a/epan/dfilter/Makefile.am
+++ b/epan/dfilter/Makefile.am
@@ -22,18 +22,16 @@
include ../../Makefile.am.inc
if HAVE_WARNINGS_AS_ERRORS
-AM_NON_GENERATED_CFLAGS = -Werror
+AM_CFLAGS = -Werror
endif
include Makefile.common
-noinst_LTLIBRARIES = libdfilter_generated.la libdfilter.la
+noinst_LTLIBRARIES = libdfilter.la
CLEANFILES = \
libdfilter.a \
libdfilter.la \
- libdfilter_generated.a \
- libdfilter_generated.la \
*~
DISTCLEANFILES = \
@@ -47,24 +45,16 @@ MAINTAINERCLEANFILES = \
AM_CPPFLAGS = -I$(srcdir)/../.. -I$(srcdir)/.. -I$(srcdir)/$(LEMON)
-#Since code generated by lex may trigger gcc warnings, we are now generating two
-#libraries. A single library is generated with the lex code without the barrier
-#"stop on warning". An other library is generated from the remaining source
-#files with the "stop on warning" barrier.
-libdfilter_la_SOURCES = $(NONGENERATED_C_FILES) $(NONGENERATED_HEADER_FILES)
-libdfilter_la_CFLAGS = $(AM_NON_GENERATED_CFLAGS)
-
-libdfilter_generated_la_SOURCES = \
- $(GENERATED_C_FILES) \
+libdfilter_la_SOURCES = \
+ $(NONGENERATED_C_FILES) \
+ $(NONGENERATED_HEADER_FILES) \
+ $(GENERATED_C_FILES) \
$(GENERATED_HEADER_FILES)
-nodist_libdfilter_generated_la_SOURCES = \
+nodist_libdfilter_la_SOURCES = \
$(NODIST_GENERATED_C_FILES) \
$(NODIST_GENERATED_HEADER_FILES)
-libdfilter_la_LIBADD = libdfilter_generated.la
-libdfilter_la_DEPENDENCIES = libdfilter_generated.la
-
EXTRA_DIST = \
$(GENERATOR_FILES) \
Makefile.common \