aboutsummaryrefslogtreecommitdiffstats
path: root/epan/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'epan/configure.in')
-rw-r--r--epan/configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/epan/configure.in b/epan/configure.in
index 05b98cde91..0d45c24455 100644
--- a/epan/configure.in
+++ b/epan/configure.in
@@ -1,4 +1,4 @@
-# $Id: configure.in,v 1.9 2001/07/13 00:55:53 guy Exp $
+# $Id: configure.in,v 1.10 2001/07/13 01:34:13 guy Exp $
dnl
dnl Process this file with autoconf 2.13 or later to produce a
dnl configure script; 2.12 doesn't generate a "configure" script that
@@ -82,6 +82,18 @@ AC_CHECK_HEADERS(sys/param.h sys/socket.h sys/stat.h sys/time.h sys/types.h)
AC_CHECK_HEADERS(netinet/in.h)
AC_CHECK_HEADERS(arpa/inet.h arpa/nameser.h)
+dnl ipv6 check
+AC_ARG_ENABLE(ipv6,
+[ --enable-ipv6 use ipv6 name resolution, if available. [default=yes]],,enable_ipv6=yes)
+
+AC_MSG_CHECKING(whether to enable ipv6 name resolution if available)
+if test "x$enable_ipv6" = "xno" ; then
+ AC_MSG_RESULT(no)
+else
+ AC_MSG_RESULT(yes)
+ AC_ETHEREAL_IPV6_STACK
+fi
+
AC_CHECK_FUNC(inet_aton, INET_ATON_O="",
INET_ATON_O="inet_aton.o")
if test "$ac_cv_func_inet_aton" = no ; then