aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules8
2 files changed, 9 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 1a31c1000f..d997c02046 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: net
Priority: optional
Maintainer: Balint Reczey <balint@balintreczey.hu>
Standards-Version: 3.9.5
-Build-Depends: libgtk-3-dev, hardening-includes,
+Build-Depends: libgtk-3-dev, hardening-includes, lsb-release,
# enable Qt 5 related dependencies for Qt 5-enabled build
qtbase5-dev, qtbase5-dev-tools, qttools5-dev, qttools5-dev-tools,
qtmultimedia5-dev, libqt5svg5-dev,
diff --git a/debian/rules b/debian/rules
index 1189ab2208..37403cb700 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,10 +7,18 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
+distrelease := $(shell lsb_release -cs)
+ifeq ($(distrelease),n/a)
+ distrelease := sid
+endif
+
# This has to be exported to make some magic below work.
export DH_OPTIONS
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+ifeq (,$(filter $(distrelease),wheezy))
+export DEB_LDFLAGS_MAINT_APPEND = -Wl,-Bsymbolic
+endif
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
VERSION := $(shell dpkg-parsechangelog | sed -n 's/^Version: \(.*\)-.*/\1/p')