aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 86fb03f8f4..5ebfa04c7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2665,10 +2665,10 @@ AC_C_BIGENDIAN
# XXX - do we need this?
AC_PROG_GCC_TRADITIONAL
-AC_CHECK_FUNC(getopt,
+AC_CHECK_FUNC(getopt_long,
[
GETOPT_LO=""
- AC_DEFINE(HAVE_GETOPT, 1, [Define to 1 if you have the getopt function.])
+ AC_DEFINE(HAVE_GETOPT_LONG, 1, [Define to 1 if you have the getopt_long function.])
],
GETOPT_LO="wsgetopt.lo")
AC_SUBST(GETOPT_LO)