aboutsummaryrefslogtreecommitdiffstats
path: root/caputils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'caputils/CMakeLists.txt')
-rw-r--r--caputils/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/caputils/CMakeLists.txt b/caputils/CMakeLists.txt
index 4f6a9ef130..21722c434e 100644
--- a/caputils/CMakeLists.txt
+++ b/caputils/CMakeLists.txt
@@ -68,3 +68,20 @@ add_library(caputils STATIC
set_target_properties(caputils PROPERTIES
LINK_FLAGS "${WS_LINK_FLAGS}"
FOLDER "Libs")
+
+CHECKAPI(
+ NAME
+ caputils-base
+ SWITCHES
+ -g deprecated-gtk
+ SOURCES
+ ${CAPUTILS_SRC}
+)
+CHECKAPI(
+ NAME
+ caputils-todo
+ SWITCHES
+ -M -g deprecated-gtk-todo
+ SOURCES
+ ${CAPUTILS_SRC}
+)