aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-12-19 18:53:31 -0800
committerGuy Harris <guy@alum.mit.edu>2014-12-20 02:54:04 +0000
commitb73689649059060c5876a8ae281a2ded58a1b8fc (patch)
treea2b18d7154626619a3e597fd211c4e631c3414a2 /wsutil/Makefile.am
parent201a7e7d689bef213a0d303601c6ac41d02a21be (diff)
Handle floorl() the same way we handle other not-on-all-platforms functions.
Use AC_CHECK_FUNC() for it, define FLOORL_LO to floorl.lo if we *don't* have it, add FLOORL_LO to the list of items conditionally built in libwsutil, and include "wsutil/floor.h" only if HAVE_FLOORL is *not* defined, as that means it's *not* supplied by the platform and thus *not* declared in <math.h>. Also, use the standard export stuff in wsutil/floor.h. Change-Id: Ic24aa69f65f2d15450d8b84b0c2b0c58f38edebe Reviewed-on: https://code.wireshark.org/review/5901 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index fe998c40c9..99db32a887 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -31,6 +31,7 @@ libwsutil_abi_INCLUDES = \
# Optional objects that I know how to build. These will be
# linked into libwsutil if necessary.
wsutil_optional_objects = \
+ @FLOORL_LO@ \
@GETOPT_LO@ \
@INET_ATON_LO@ \
@INET_NTOP_LO@ \