aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2016-07-15 13:59:23 -0700
committerJoão Valverde <j@v6e.pt>2016-07-21 20:09:03 +0000
commit913e0f408c48f3baf6933807f9cfe4195fde5c75 (patch)
tree285e4dd8b2e5c660bc04b0256323de6622082a10 /wsutil/Makefile.am
parent97d194cd3cb7fa3806a7bb83f83f06ee2eda418b (diff)
Use Windows CRT string functions in some places.
Copy wsutil/wsprintf.h from change 16537. Update it to use functions appropriate to Visual C++ >= 2015, < 2015, and everything else. Add notes about specific API issues. Update epan/expert.c to use ws_snprintf, since the VS profiler shows it as a minor hot spot. This reduces load time for a large-ish capture from ~14s to ~12s here. Migrate a previous column-utils change. Change-Id: Id4064b7c06c35fd447b63c73f731afee181df4f9 Reviewed-on: https://code.wireshark.org/review/16483 Reviewed-by: Gerald Combs <gerald@wireshark.org> Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 95c57d2582..2cedf9ddbb 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -89,7 +89,8 @@ libwsutil_nonrepl_INCLUDES = \
utf8_entities.h \
ws_cpuid.h \
ws_mempbrk.h \
- ws_mempbrk_int.h
+ ws_mempbrk_int.h \
+ ws_printf.h
# Header files for functions in libwsutil's ABI on this platform.
libwsutil_abi_INCLUDES = \