aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/Makefile.am
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-08-01 23:34:47 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-08-01 23:34:47 +0000
commit2df54da6e2b70777154d38ce3923093568358285 (patch)
tree4bdb887d40a0a5fee501c0bd30f31388019fbe32 /wsutil/Makefile.am
parent6ae3372687957dfbda6352598aee00e84f83f7da (diff)
Move a bunch of the crypt modules and pint.h into wsutil.
This means wsutil now links against libcrypt. Protect a bunch of the crypt header files from multiple inclusion. svn path=/trunk/; revision=51100
Diffstat (limited to 'wsutil/Makefile.am')
-rw-r--r--wsutil/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/wsutil/Makefile.am b/wsutil/Makefile.am
index 828995c89f..4b35e8484f 100644
--- a/wsutil/Makefile.am
+++ b/wsutil/Makefile.am
@@ -29,15 +29,15 @@ wsutil_optional_objects =
if NEED_GETOPT_LO
wsutil_optional_objects += @GETOPT_LO@
endif
-
+
if NEED_INET_ATON_LO
wsutil_optional_objects += @INET_ATON_LO@
endif
-
+
if NEED_INET_NTOP_LO
wsutil_optional_objects += @INET_NTOP_LO@
endif
-
+
if NEED_INET_PTON_LO
wsutil_optional_objects += @INET_PTON_LO@
endif
@@ -65,6 +65,7 @@ lib_LTLIBRARIES = libwsutil.la
libwsutil_la_LDFLAGS = -version-info 0:0:0 @LDFLAGS_SHAREDLIB@
AM_CPPFLAGS = -I$(srcdir)/..
+ $(LIBGCRYPT_CFLAGS)
libwsutil_la_SOURCES = \
$(LIBWSUTIL_SRC) \
@@ -88,6 +89,7 @@ libwsutil_la_DEPENDENCIES= \
libwsutil_la_LIBADD = \
@GLIB_LIBS@ \
+ @LIBGCRYPT_LIBS@ \
$(wsutil_optional_objects)
EXTRA_DIST = \