aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-06-29 14:37:21 -0700
committerGuy Harris <guy@alum.mit.edu>2014-06-29 23:03:24 +0000
commitfe42762f236e23fefe47e67b6c248507d0ac5c8a (patch)
tree57947515414aa27789b5aea2b1e4d32c0da7e97e /wsutil/CMakeLists.txt
parentdd63ae2b8c889aa91577efe4621e6d0fe5432a99 (diff)
Move some more stuff into wsutil.
Move the routines to parse numerical command-line arguments there. Make cmdarg_err() and cmdarg_err_cont() routines in wsutil that just call routines specified by a call to cmdarg_err_init(), and have programs supply the appropriate routines to it. Change-Id: Ic24fc758c0e647f4ff49eb91673529bcb9587b01 Reviewed-on: https://code.wireshark.org/review/2704 Reviewed-by: Evan Huus <eapache@gmail.com> Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 0157e74785..d8e2f04de1 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -45,6 +45,8 @@ set(WSUTIL_FILES
base64.c
bitswap.c
cfutils.c
+ clopts_common.c
+ cmdarg_err.c
compiler_info.c
copyright_info.c
cpu_info.c