aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2019-04-30 15:48:06 -0700
committerGerald Combs <gerald@wireshark.org>2019-05-01 17:51:59 +0000
commitcec5991f40887b4b2add594e7d82857d475224aa (patch)
tree5f4e0dc3846b2cce60c0f22bef7c111236b84957 /wsutil/CMakeLists.txt
parent3a2e290c331f03b2467d49d5c04151aab9f1a4d9 (diff)
Windows: Modernize our WSAStartup usage.
Make sure we link each application that calls WSAStartup with ws2_32.lib. Pass version 2.2 to WSAStartup. Wikipedia says it was introduced in 1996, so we should be OK. Ping-Bug: 15711 Change-Id: I431839e930e7c646669af7373789640b5180ec28 Reviewed-on: https://code.wireshark.org/review/33033 Petri-Dish: Gerald Combs <gerald@wireshark.org> Reviewed-by: Tomasz Moń <desowin@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 030dc9e3ce..2eb9e70d70 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -268,7 +268,7 @@ target_link_libraries(wsutil
${GLIB2_LIBRARIES}
${PCAP_LIBRARIES}
${GCRYPT_LIBRARIES}
- ${WIN_WSOCK32_LIBRARY}
+ ${WIN_WS2_32_LIBRARY}
${GNUTLS_LIBRARIES}
)