aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2018-12-31 16:55:23 -0800
committerGuy Harris <guy@alum.mit.edu>2019-01-01 02:07:06 +0000
commitba589a4e445a8ad8054073eff846087fc61c9ef8 (patch)
treeac5bcee756541531a1864ce01c60f3f0395e0dc5 /wsutil/CMakeLists.txt
parent5a5d236d1f1c0149e9e9fa291cbd251006a8dd40 (diff)
Move some command-line-oriented routines from wsutil to ui.
cmdarg_err() is for reporting errors for command-line programs and command-line errors in GUI programs; it's not something for any of the Wireshark libraries to use. The various routines for parsing numerical command-line arguments are not for general use, they're just for use when parsing arguments. Change-Id: I100bd4a55ab8ee4497f41d9651b0c5670e6c1e7f Reviewed-on: https://code.wireshark.org/review/31281 Petri-Dish: Guy Harris <guy@alum.mit.edu> Tested-by: Petri Dish Buildbot Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index bb8f57a018..af103b3747 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -20,8 +20,6 @@ set(WSUTIL_PUBLIC_HEADERS
bits_ctz.h
bitswap.h
buffer.h
- clopts_common.h
- cmdarg_err.h
color.h
copyright_info.h
cpu_info.h
@@ -80,8 +78,6 @@ set(WSUTIL_COMMON_FILES
base32.c
bitswap.c
buffer.c
- clopts_common.c
- cmdarg_err.c
copyright_info.c
crash_info.c
crc10.c