aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorJoão Valverde <j@v6e.pt>2021-07-12 21:22:05 +0100
committerWireshark GitLab Utility <gerald+gitlab-utility@wireshark.org>2021-07-26 14:56:11 +0000
commit7f9c1f5f92c131354fc8b2b88d473706786064c0 (patch)
tree9249c0eda50dea18e8b85e8aeb8c1d3c98a007cb /wsutil/CMakeLists.txt
parent8310665ae707b589e04167ef9bd2aed6f71651f3 (diff)
Move wmem to wsutil
This allows wmem to be used from other libraries, namely wsutil. It is often the case that a funtion exists in wsutil and cannot be used with a wmem scope, requiring some code duplication or extra memory allocations, or vice-versa, code in epan cannot be moved to wsutil because it has a wmem dependency. To this end wmem is moved to wsutil. Scope management remains part of epan because those scope semantics are specific to dissection.
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 9e9b62c89c..e636bb3196 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -11,6 +11,8 @@ add_definitions(-DPLUGIN_DIR=\"${CMAKE_INSTALL_PREFIX}/${PLUGIN_INSTALL_LIBDIR}\
add_definitions(-DEXTCAP_DIR=\"${CMAKE_INSTALL_PREFIX}/${EXTCAP_INSTALL_LIBDIR}\")
add_definitions(-DDATA_DIR=\"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}\")
+add_subdirectory(wmem)
+
set(WSUTIL_PUBLIC_HEADERS
802_11-utils.h
adler32.h
@@ -248,6 +250,7 @@ endif()
add_library(wsutil
${WSUTIL_FILES}
+ $<TARGET_OBJECTS:wmem>
${CMAKE_BINARY_DIR}/image/libwsutil.rc
)