aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2022-04-06 13:18:47 -0700
committerGerald Combs <gerald@wireshark.org>2022-04-07 21:41:36 +0000
commit54553de59d24175ede07d3b423080cb9824c3360 (patch)
tree0d6c80ca8e3eed65d3abe8fefd2772b5b6c0e87d /wsutil/CMakeLists.txt
parentddbafcd9ba98cb920942e5a41fb77bfe0978063e (diff)
wsutil: Use a separate "extlog" directory for Logwolf extcaps.
If we're running in the Logwolf configuration namespace, look for extcaps in a directory named "extlog". This paves the way for adding log-specific capture utilities.
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index 7ee6cd212b..07b3821283 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -9,6 +9,7 @@
add_definitions(-DPLUGIN_DIR=\"${CMAKE_INSTALL_PREFIX}/${PLUGIN_INSTALL_LIBDIR}\")
add_definitions(-DEXTCAP_DIR=\"${CMAKE_INSTALL_PREFIX}/${EXTCAP_INSTALL_LIBDIR}\")
+add_definitions(-DEXTLOG_DIR=\"${CMAKE_INSTALL_PREFIX}/${EXTLOG_INSTALL_LIBDIR}\")
add_definitions(-DDATA_DIR=\"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_DATADIR}\")
add_subdirectory(wmem)