aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Mann <mmann78@netscape.net>2014-03-18 08:17:28 -0400
committerEvan Huus <eapache@gmail.com>2014-06-19 18:23:09 +0000
commit53594f34e499d309c66f56b22f373bf502802620 (patch)
treeee4cc1e0f12ec8738ab70032c493b5ec5acfb1b4 /wsutil/CMakeLists.txt
parent0b245a4cf8a46110ef0803e091e11fd894e017b2 (diff)
Dissectors for totemnet and totemsrp protocols implemented in corosync cluster engine. Bug 3232.
From Masatake YAMATO changes in patch3 (Masatake YAMATO): * Fix a typo(s/Sequnce/Sequence/) * Use variable len instead of a number literal * Put _U_ marker to length parameter of dissect_corosync_totemsrp_ip_address * Use tvb_report_length instread of tvb_length changes in patch5 (Masatake YAMATO): * packet-corosync-totemsrp.c: Adapt to new dissector_try_heuristic interface + pass hdtbl_entry argument to dissector_try_heuristic. * packet-corosync-totemnet.c: Initialize corosync_totemnet_port to 5405 changes in patch6 (Masatake YAMATO): * packet-corosync-totemsrp.c: Use tvb_reported_length instead of tvb_length. * packet-corosync-totemsrp.c: Remove unnecessary trailing space in string literals. * packet-corosync-totemnet.c: Remove SVN Id tag in a comment. changes in patch8 (Masatake YAMATO): * packet-corosync-totemnet.c: Remove SVN Id tag in comment(again). * packet-corosync-totemsrp.c: Use val_to_str_const instead of val_to_str. changes in patch9 (Masatake YAMATO): * wsutil/sober128.[ch]: New files derived from packet-corosync-totemnet.c. Decryption code is moved here. * packet-corosync-totemnet.c: Remove all decryption code from this file. Change-Id: Id832d9c5ce1be1668c857c9bbf39e8a84c31880c Reviewed-on: https://code.wireshark.org/review/725 Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index ab4dfd83cc..95ffa0220e 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -65,6 +65,7 @@ set(WSUTIL_FILES
plugins.c
privileges.c
sha1.c
+ sober128.c
strnatcmp.c
str_util.c
rc4.c