aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorJeff Morriss <jeff.morriss.ws@gmail.com>2013-08-01 23:34:47 +0000
committerJeff Morriss <jeff.morriss.ws@gmail.com>2013-08-01 23:34:47 +0000
commit2df54da6e2b70777154d38ce3923093568358285 (patch)
tree4bdb887d40a0a5fee501c0bd30f31388019fbe32 /wsutil/CMakeLists.txt
parent6ae3372687957dfbda6352598aee00e84f83f7da (diff)
Move a bunch of the crypt modules and pint.h into wsutil.
This means wsutil now links against libcrypt. Protect a bunch of the crypt header files from multiple inclusion. svn path=/trunk/; revision=51100
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index cce06d373f..d40e2cc630 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -35,6 +35,7 @@ set(WSUTIL_FILES
# @INET_PTON_LO@ # inet_pton.c
# @STRNCASECMP_LO@ # strncasecmp.c
# @STRPTIME_LO@ # strptime.c
+ aes.c
airpdcap_wep.c
crash_info.c
crc10.c
@@ -46,12 +47,18 @@ set(WSUTIL_FILES
crc8.c
crc11.c
crcdrm.c
+ des.c
+ eax.c
g711.c
+ md4.c
+ md5.c
mpeg-audio.c
nstime.c
privileges.c
+ sha1.c
strnatcmp.c
str_util.c
+ rc4.c
report_err.c
tempfile.c
type_util.c
@@ -61,6 +68,7 @@ set(WSUTIL_FILES
set(wsutil_LIBS
${GLIB2_LIBRARIES}
+ ${GCRYPT_LIBRARIES}
)
set(CLEAN_FILES