aboutsummaryrefslogtreecommitdiffstats
path: root/wsutil/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-07-03 10:16:25 -0700
committerGuy Harris <guy@alum.mit.edu>2014-07-03 17:16:54 +0000
commit06bd8045d75793f21a344fdbf9dd827229c6ec20 (patch)
treeb1c0c5556362d503b791283e5e52345c0832e994 /wsutil/CMakeLists.txt
parent66b02c75eda0c5c7430ff62f641390ad415e826c (diff)
Make wsutil depend on gitversion.
wsutil contains the only code that uses version.h; make the dependency explicit, to see whether that fixes the current build issues with Debian packaging. Also, get rid of all *other* dependencies on gitversion. Change-Id: I89fa5e4112633b83a1a7dfa349bc337e3688575f Reviewed-on: https://code.wireshark.org/review/2823 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'wsutil/CMakeLists.txt')
-rw-r--r--wsutil/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/wsutil/CMakeLists.txt b/wsutil/CMakeLists.txt
index e5e73bc033..1d5ad1c7d4 100644
--- a/wsutil/CMakeLists.txt
+++ b/wsutil/CMakeLists.txt
@@ -139,6 +139,8 @@ add_library(wsutil ${LINK_MODE_LIB}
../image/libwsutil.rc
)
+add_dependencies(wsutil gitversion)
+
set(FULL_SO_VERSION "0.0.0")
set_target_properties(wsutil PROPERTIES COMPILE_DEFINITIONS "WS_BUILD_DLL")