aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-10-05 17:37:27 +0100
committerJoão Valverde <j@v6e.pt>2017-10-18 17:19:18 +0000
commit45fbb287b42c47d9fc84c1abc9158a7d24333c79 (patch)
tree6c68de666c7cab395d50317a62129944c6dbf46b /wiretap/Makefile.am
parentc703ba52adc02c83245a5d428e6943d4a4a0f995 (diff)
autotools: Remove abi-compliance-checker code
It's been broken for over a year, needs to be modernized and as implemented it's a maintenance nightmare. Get rid of it. Ping-Bug: 13036 Change-Id: I34a6e4c28b6d3b96dd6550dd21e9cbeaf050d58f Reviewed-on: https://code.wireshark.org/review/23967 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'wiretap/Makefile.am')
-rw-r--r--wiretap/Makefile.am24
1 files changed, 0 insertions, 24 deletions
diff --git a/wiretap/Makefile.am b/wiretap/Makefile.am
index 120de8aa65..e083b11e66 100644
--- a/wiretap/Makefile.am
+++ b/wiretap/Makefile.am
@@ -246,30 +246,6 @@ ascend.c: $(srcdir)/ascend.y ascend_scanner_lex.h
version_info.c: $(top_srcdir)/version_info.c
$(AM_V_LN_S)$(LN_S) $<
-# ABI compliance checker can be obtained from
-# http://ispras.linux-foundation.org/index.php/ABI_compliance_checker
-# Checked using version 1.21.12
-#
-# (f)lex generated headers are not part of API and may not include
-# all needed headers for used types
-dumpabi-libwiretap: all abi-descriptor.xml
- rm -rf abi-check-headers abi_dumps .libs/*.abi.tar.gz
- mkdir abi-check-headers
- cp *.h ../ws_symbol_export.h abi-check-headers/
- rm abi-check-headers/*_lex.h abi-check-headers/ascend.h
- abi-compliance-checker -log-path abi_logs/log.txt -l libwiretap -v1 `readlink .libs/libwiretap.so | sed 's/.*\.so\.//'` \
- -relpath $(abs_srcdir) -dump-abi abi-descriptor.xml || \
- cat abi_logs/log.txt
- cp -f abi_dumps/libwiretap/libwiretap_* .libs/
- cd .libs && ln -sf libwiretap_*.abi.tar.gz libwiretap.abi.tar.gz
-
-maintainer-clean-local: clean-dumpabi-libwiretap
-
-.PHONY: clean-dumpabi-libwiretap
-
-clean-dumpabi-libwiretap:
- rm -rf abi-check-headers abi_dumps .libs/*.abi.tar.gz abi_logs abi-descriptor.xml
-
checkapi:
## 'abort' checking disabled for now pending resolution of existing use of g_assert & g_error
## $(PERL) $(top_srcdir)/tools/checkAPIs.pl -g abort -g termoutput \