aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Perry <boolean263@protonmail.com>2023-01-24 16:47:14 -0500
committerAndersBroman <a.broman58@gmail.com>2023-04-13 13:26:13 +0000
commitfd8464e05df27c3f967d1d9503b6ca3f76605585 (patch)
tree956118e205dad47cd0a297ef22a4bc575503f890 /wiretap/CMakeLists.txt
parent56b32bc5dce4db12d57da9dc2d2d01a2f1c23751 (diff)
Add rtpdump read and parse support
Add a wiretap file format reader to read rtpdump files. Generates "Exported PDU" data from the header of the rtpdump file. Add MIME file format read support for rtpdump files. Change the default extension for exporting rtpdump files to '*.rtp' as per the rtptools project's recommendation. Wireshark generates rtpdump files slightly differently from how rtpdump itself works. Both the wiretap reader and the MIME reader examine the text and binary headers to determine the most appropriate presentation of information to the user.
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index 51b6230de0..b021208335 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -81,9 +81,10 @@ set(WIRETAP_C_MODULE_FILES
${CMAKE_CURRENT_SOURCE_DIR}/pcap-common.c
${CMAKE_CURRENT_SOURCE_DIR}/peekclassic.c
${CMAKE_CURRENT_SOURCE_DIR}/peektagged.c
- ${CMAKE_CURRENT_SOURCE_DIR}/rfc7468.c
${CMAKE_CURRENT_SOURCE_DIR}/pppdump.c
${CMAKE_CURRENT_SOURCE_DIR}/radcom.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/rfc7468.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/rtpdump.c
${CMAKE_CURRENT_SOURCE_DIR}/ruby_marshal.c
${CMAKE_CURRENT_SOURCE_DIR}/snoop.c
${CMAKE_CURRENT_SOURCE_DIR}/stanag4607.c