aboutsummaryrefslogtreecommitdiffstats
path: root/wiretap/CMakeLists.txt
diff options
context:
space:
mode:
authorMaksim Salau <maksim.salau@gmail.com>2019-06-27 21:19:53 +0300
committerAnders Broman <a.broman58@gmail.com>2019-07-11 04:44:00 +0000
commit8bb5320cb2c2574f657679e387068d27bc178fdb (patch)
tree88a8c69f849a63b3d5fcecd73b11969282cfd11a /wiretap/CMakeLists.txt
parentdb9ec7fc46dfa685fd4ff0376d6ea594f73cf081 (diff)
wiretap: Add support of candump logs
The change adds ability to import text logs produced by the candump tool. E.g.: candump -L can0 -or- candump -l can0 The whole file is read and converted into a temporary PCAPNG file with Exported PDU packets containing SocketCAN frames. Bug: 15889 Change-Id: I5ad93dca96d6e955a4b21cf624f0553e60f060f6 Reviewed-on: https://code.wireshark.org/review/33800 Petri-Dish: Jim Young <jim.young.ws@gmail.com> Tested-by: Petri Dish Buildbot Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'wiretap/CMakeLists.txt')
-rw-r--r--wiretap/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/wiretap/CMakeLists.txt b/wiretap/CMakeLists.txt
index dddb894b00..d7ea972133 100644
--- a/wiretap/CMakeLists.txt
+++ b/wiretap/CMakeLists.txt
@@ -27,6 +27,7 @@ set(WIRETAP_NONGENERATED_FILES
ber.c
btsnoop.c
camins.c
+ candump.c
capsa.c
catapult_dct2000.c
commview.c
@@ -90,6 +91,7 @@ set(WIRETAP_FILES ${WIRETAP_NONGENERATED_FILES})
add_lex_files(LEX_FILES WIRETAP_FILES
ascend_scanner.l
+ candump_scanner.l
k12text.l
)
@@ -97,6 +99,10 @@ add_yacc_files(YACC_FILES WIRETAP_FILES
ascend.y
)
+add_lemon_files(LEMON_FILES WIRETAP_FILES
+ candump_parser.lemon
+)
+
#
# All files are warning-clean. (Let's keep it that way.)
#