aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-06-11 15:05:44 -0700
committerGerald Combs <gerald@wireshark.org>2015-06-16 03:45:54 +0000
commitece4b01f218ab4e71233580e199e830b83958c99 (patch)
treef7503d8f097b6e3f6406dd3f6b0c69bb46b97909 /ui/qt/CMakeLists.txt
parent2a3fa1418544469e7dc6f0e0fddb6eaab507b71a (diff)
Add the wireless toolbar.
Add the wireless toolbar to the Qt UI. Start adding AirPcap support to ui/80211_utils. Add FCS validation routines to ws80211_utils. Move a bunch of AirPcap routines that require epan from caputils to ui/gtk. They were required for driver key management, which we'll leave to the AirPcap Control Panel in the Qt UI. Move frequency-utils to wsutil. Change-Id: I44446758046621d183f5c2ba9f6526bf01e084f1 Reviewed-on: https://code.wireshark.org/review/8910 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 712c02e250..face9b58d6 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -111,6 +111,7 @@ set(WIRESHARK_QT_HEADERS
traffic_table_dialog.h
uat_dialog.h
voip_calls_dialog.h
+ wireless_frame.h
wireshark_application.h
wireshark_dialog.h
)
@@ -229,6 +230,7 @@ set(WIRESHARK_QT_SRC
traffic_table_dialog.cpp
uat_dialog.cpp
voip_calls_dialog.cpp
+ wireless_frame.cpp
wireshark_application.cpp
wireshark_dialog.cpp
)
@@ -319,6 +321,7 @@ set(WIRESHARK_QT_UI
traffic_table_dialog.ui
uat_dialog.ui
voip_calls_dialog.ui
+ wireless_frame.ui
)
if(HAVE_PCAP_REMOTE)