aboutsummaryrefslogtreecommitdiffstats
path: root/ui/qt/CMakeLists.txt
diff options
context:
space:
mode:
authorIrene Ruengeler <ruengeler@wireshark.org>2014-06-04 11:03:59 +0200
committerAnders Broman <a.broman58@gmail.com>2014-06-12 05:54:59 +0000
commitdf8c4bf2644d39d66613868256d918346d56aef8 (patch)
treeb0a04ebc37a508598b5e49652ebe83219fff47c2 /ui/qt/CMakeLists.txt
parent428c5b9448a510da1d8bc903f59364ef830585ac (diff)
Capture Interfaces Dialog:
- allow to change the interface options in the table - save the options to preferences when the dialog is left - add a field for setting a capture filter for all selected interfaces - add a "Compile BPF" button and a window to show the compiled filter output - try to address Alexis' and Evan's comments Change-Id: Ic1272e29183ec80e2d2f4b3e494c79dabe2c3b6f Reviewed-on: https://code.wireshark.org/review/1946 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Alexis La Goutte <alexis.lagoutte@gmail.com> Reviewed-by: Anders Broman <a.broman58@gmail.com>
Diffstat (limited to 'ui/qt/CMakeLists.txt')
-rw-r--r--ui/qt/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/ui/qt/CMakeLists.txt b/ui/qt/CMakeLists.txt
index 8f3702f7cd..5b4e51e2bd 100644
--- a/ui/qt/CMakeLists.txt
+++ b/ui/qt/CMakeLists.txt
@@ -37,6 +37,7 @@ set(WIRESHARK_QT_HEADERS
color_dialog.h
color_utils.h
column_preferences_frame.h
+ compiled_filter_output.h
decode_as_dialog.h
display_filter_combo.h
display_filter_edit.h
@@ -117,6 +118,7 @@ set(WIRESHARK_QT_SRC
color_utils.cpp
capture_preferences_frame.cpp
column_preferences_frame.cpp
+ compiled_filter_output.cpp
decode_as_dialog.cpp
display_filter_combo.cpp
display_filter_edit.cpp
@@ -197,6 +199,7 @@ set(WIRESHARK_QT_UI
capture_preferences_frame.ui
capture_interfaces_dialog.ui
column_preferences_frame.ui
+ compiled_filter_output.ui
decode_as_dialog.ui
export_object_dialog.ui
export_pdu_dialog.ui