aboutsummaryrefslogtreecommitdiffstats
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-09-18 14:09:55 -0700
committerGerald Combs <gerald@wireshark.org>2014-09-20 19:54:04 +0000
commit8576e1c103cb0606d100c31b9794bcdb61bd50c6 (patch)
tree429fcda5b0cf673edf8411b2b65e79f2c8bd9d71 /ui/gtk/Makefile.am
parent801824b8a7a9885ab066ee7d10e7e03a2a948315 (diff)
Qt: Add stock icons.
The new icons are patterned after the existing capture icons. They could probably benefit from some adjustments here and there. Start moving toward icon names and a directory layout compliant with freedesktop.org's Icon Naming Specification and Icon Theme Specification. We aren't fully compliant and might never be but anyone with exposure to FDO icon themes should at least know where everything is. Make Capture Start (x-capture-start) the first icon in the toolbar. Define the Colorize Packets, Auto Scroll, and zoom icons even though the Qt UI doesn't use them yet. Leave the Capture Filter, Display Filter, Coloring Rules, Preferences, and Help icons off for now. The GTK+ toolbar is overly cluttered and I'm not sure they're necessary. Try not to break ui/gtk/toolbar_icons.h. Remove welcome.qrc. I initially added it in case we needed to overlay the welcome screen with translucent .pngs but that never happened. To do: - Move the old GTK+ icons to their own directory. - Find a better name for the "toolbar" directory. "stock"? - Make the toolbar configurable. Change-Id: Ie07592113d307b8db786aedace672312a870fe38 Reviewed-on: https://code.wireshark.org/review/4182 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 0b64cf3e0b..e521f74b79 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -129,12 +129,7 @@ pipe_icon.h:
TOOLBAR_COMMON_ICONS = \
capture_interfaces \
- capture_options_alt1 \
- capture_restart \
- capture_start \
- capture_stop \
- gnome_emblem_web \
- toolbar_wireshark_file
+ gnome_emblem_web
toolbar_icons.h:
echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
@@ -145,6 +140,13 @@ toolbar_icons.h:
for icon24 in $(TOOLBAR_COMMON_ICONS) ; do \
gdk-pixbuf-csource --raw --name=$${icon24}_24_pb_data $(top_srcdir)/image/toolbar/$${icon24}_24.png >> $@ ;\
done
+ for icon_size in 16 24 ; do \
+ gdk-pixbuf-csource --raw --name=toolbar_wireshark_file_$${icon_size}_pb_data $(top_srcdir)/image/toolbar/$${icon_size}x$${icon_size}/x-capture-file-save.png >> $@ ;\
+ gdk-pixbuf-csource --raw --name=capture_options_alt1_$${icon_size}_pb_data $(top_srcdir)/image/toolbar/$${icon_size}x$${icon_size}/x-capture-options.png >> $@ ;\
+ gdk-pixbuf-csource --raw --name=capture_restart_$${icon_size}_pb_data $(top_srcdir)/image/toolbar/$${icon_size}x$${icon_size}/x-capture-restart.png >> $@ ;\
+ gdk-pixbuf-csource --raw --name=capture_start_$${icon_size}_pb_data $(top_srcdir)/image/toolbar/$${icon_size}x$${icon_size}/x-capture-start.png >> $@ ;\
+ gdk-pixbuf-csource --raw --name=capture_stop_$${icon_size}_pb_data $(top_srcdir)/image/toolbar/$${icon_size}x$${icon_size}/x-capture-stop.png >> $@ ;\
+ done
layouts.h:
echo "/* This file was automatically generated. DO NOT EDIT. */" > $@