aboutsummaryrefslogtreecommitdiffstats
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2017-12-10 17:29:40 +0000
committerJoão Valverde <j@v6e.pt>2017-12-11 02:52:28 +0000
commit5fc43fe63a07062587bc3d76256f4240221e8bc7 (patch)
tree8508ce04e5aec4e0e23ad958f9ec6a5102f93fc0 /ui/gtk/Makefile.am
parent224e24884a8b37732105bd40a0ee85d5feaaeab1 (diff)
Rewrite make-tap-reg.py in C
Change-Id: Ief5b1fffecc9712c01ff10292c403b7c84a5908a Reviewed-on: https://code.wireshark.org/review/24756 Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am23
1 files changed, 2 insertions, 21 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index 14e375df3c..035a00f29a 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -269,10 +269,6 @@ endif
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) $(GTK_CFLAGS) \
$(PORTAUDIO_INCLUDES)
-CLEANFILES = \
- wireshark-tap-register.c-tmp \
- wireshark-tap-register-cache.pkl
-
DISTCLEANFILES = \
$(NODIST_GENERATED_FILES)
@@ -314,23 +310,8 @@ nodist_libgtkui_a_SOURCES = \
libgtkui_a_DEPENDENCIES =
-#
-# Build "wireshark-tap-register.c", which contains a function
-# "register_all_tap_listeners()"
-# that calls the register routines for all wireshark tap listeners.
-#
-# We do this by grepping through sources.
-#
-# Formatting conventions: The name of the tap_listener_register_*
-# routines must start in column zero, or must be preceded only by
-# "void " starting in column zero, and must not be inside #if.
-#
-# The first argument is the directory in which the source files live.
-# All subsequent arguments are the files to scan.
-#
-wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) Makefile_custom.common $(top_srcdir)/tools/make-tap-reg.py
- @echo Making wireshark-tap-register.c
- @$(PYTHON) $(top_srcdir)/tools/make-tap-reg.py $(srcdir) taps $(WIRESHARK_TAP_SRC)
+wireshark-tap-register.c: $(WIRESHARK_TAP_SRC) ../make-taps
+ $(AM_V_GEN)../make-taps $@ $(filter %.c,$^)
wireshark-gresources.c: main.gresources.xml $(shell glib-compile-resources --sourcedir=$(top_srcdir) --generate-dependencies $(srcdir)/main.gresources.xml)
@echo Making $@