aboutsummaryrefslogtreecommitdiffstats
path: root/ui/gtk/Makefile.am
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2012-12-05 22:28:12 +0000
committerGerald Combs <gerald@wireshark.org>2012-12-05 22:28:12 +0000
commit07898cae39896087f39c31458a3eb077d44c6a95 (patch)
tree33dc28f90e6ab4ba4760f3f8ae57744b85da004e /ui/gtk/Makefile.am
parent025f5d1ecd576c1cd546fc489326dacb49647a4d (diff)
Create 16x16 and 24x24 versions of the document icon with a contrasting
border. Add them as pixbufs to ui/gtk/toolbar_icons.h and use them to replace the file icon XPM in stock_icons.c. Add modelines. svn path=/trunk/; revision=46413
Diffstat (limited to 'ui/gtk/Makefile.am')
-rw-r--r--ui/gtk/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/ui/gtk/Makefile.am b/ui/gtk/Makefile.am
index e43400c529..3cecad0e6a 100644
--- a/ui/gtk/Makefile.am
+++ b/ui/gtk/Makefile.am
@@ -132,6 +132,16 @@ pipe_icon.h:
echo >> $@
gdk-pixbuf-csource --raw --name=pipe_pb_data $(top_srcdir)/image/toolbar/pipe_16.png >> $@
+toolbar_icons.h:
+ echo "/* This file was automatically generated. DO NOT EDIT. */" > $@
+ echo >> $@
+ for icon16 in wireshark_file ; do \
+ gdk-pixbuf-csource --raw --name=toolbar_$${icon16}_16_pb_data $(top_srcdir)/image/toolbar/toolbar_$${icon16}_16.png >> $@ ;\
+ done
+ for icon24 in wireshark_file ; do \
+ gdk-pixbuf-csource --raw --name=toolbar_$${icon24}_24_pb_data $(top_srcdir)/image/toolbar/toolbar_$${icon24}_24.png >> $@ ;\
+ done
+
EXTRA_DIST = \
$(GENERATOR_FILES) \
airpcap_dlg.c \