aboutsummaryrefslogtreecommitdiffstats
path: root/ui/Makefile.am
diff options
context:
space:
mode:
authorJoão Valverde <joao.valverde@tecnico.ulisboa.pt>2016-06-21 05:06:23 +0100
committerJoão Valverde <j@v6e.pt>2016-06-30 11:04:17 +0000
commita16d401b25c85ffb7fde6c46b51cb7048112f885 (patch)
tree71ba692edcdb6f2a10ed566e18bcfbbc456cfad1 /ui/Makefile.am
parentf6c5cf953212248cbc680ef0d9b2f852cbfdb951 (diff)
Remove Makefile.common files
Now that nmake build system has been removed they are not needed anymore. Change-Id: I88075f955bb4349185859c1af4be22e53de5850f Reviewed-on: https://code.wireshark.org/review/16050 Petri-Dish: João Valverde <j@v6e.pt> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: João Valverde <j@v6e.pt>
Diffstat (limited to 'ui/Makefile.am')
-rw-r--r--ui/Makefile.am153
1 files changed, 130 insertions, 23 deletions
diff --git a/ui/Makefile.am b/ui/Makefile.am
index befc051784..91f189bd05 100644
--- a/ui/Makefile.am
+++ b/ui/Makefile.am
@@ -20,7 +20,6 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-include Makefile.common
include $(top_srcdir)/Makefile.am.inc
AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) -DDOC_DIR=\"$(docdir)\" \
@@ -28,35 +27,151 @@ AM_CPPFLAGS = $(INCLUDEDIRS) $(WS_CPPFLAGS) -DDOC_DIR=\"$(docdir)\" \
noinst_LIBRARIES = libui.a libui_dirty.a
-BUILT_SOURCES = $(GENERATED_HEADER_FILES)
+# Generated header files that we want in the distribution.
+GENERATED_HEADER_FILES = \
+ text_import_scanner_lex.h
-CLEANFILES = \
- doxygen-ui.tag \
- libui.a \
- libui_dirty.a \
- *~
+# Generated C source files that we want in the distribution.
+GENERATED_C_FILES =
-MAINTAINERCLEANFILES = \
- $(GENERATED_FILES) \
- Makefile.in
+DIRTY_GENERATED_C_FILES = \
+ text_import_scanner.c
-text_import_scanner_lex.h: text_import_scanner.c
+# All the generated files we want in the distribution.
+GENERATED_FILES = \
+ $(GENERATED_HEADER_FILES) \
+ $(GENERATED_C_FILES) \
+ $(DIRTY_GENERATED_C_FILES)
+
+# Files that generate compileable files
+GENERATOR_FILES = \
+ text_import_scanner.l
+
+WIRESHARK_UI_SRC = \
+ alert_box.c \
+ capture.c \
+ capture_ui_utils.c \
+ commandline.c \
+ console.c \
+ decode_as_utils.c \
+ export_object.c \
+ export_object_dicom.c \
+ export_object_http.c \
+ export_object_smb.c \
+ export_object_tftp.c \
+ export_pdu_ui_utils.c \
+ firewall_rules.c \
+ iface_lists.c \
+ io_graph_item.c \
+ language.c \
+ help_url.c \
+ mcast_stream.c \
+ packet_list_utils.c \
+ persfilepath_opt.c \
+ preference_utils.c \
+ profile.c \
+ proto_hier_stats.c \
+ recent.c \
+ rtp_media.c \
+ rtp_stream.c \
+ service_response_time.c \
+ software_update.c \
+ ssl_key_export.c \
+ tap_export_pdu.c \
+ tap-iax2-analysis.c \
+ tap-rlc-graph.c \
+ tap-rtp-common.c \
+ tap-sctp-analysis.c \
+ tap-sequence-analysis.c \
+ tap-tcp-stream.c \
+ text_import.c \
+ time_shift.c \
+ traffic_table_ui.c \
+ util.c \
+ voip_calls.c
+
+WIRESHARK_UI_INCLUDES = \
+ alert_box.h \
+ all_files_wildcard.h \
+ capture.h \
+ capture_globals.h \
+ capture_ui_utils.h \
+ commandline.h \
+ console.h \
+ decode_as_utils.h \
+ export_object.h \
+ export_pdu_ui_utils.h \
+ last_open_dir.h \
+ file_dialog.h \
+ help_url.h \
+ packet_list_utils.h \
+ firewall_rules.h \
+ iface_lists.h \
+ io_graph_item.h \
+ language.h \
+ mcast_stream.h \
+ main_statusbar.h \
+ persfilepath_opt.h \
+ preference_utils.h \
+ profile.h \
+ progress_dlg.h \
+ proto_hier_stats.h \
+ recent.h \
+ recent_utils.h \
+ rtp_media.h \
+ rtp_stream.h \
+ service_response_time.h \
+ simple_dialog.h \
+ software_update.h \
+ ssl_key_export.h \
+ tap_export_pdu.h \
+ tap-iax2-analysis.h \
+ tap-rlc-graph.h \
+ tap-rtp-analysis.h \
+ tap-rtp-common.h \
+ tap-sctp-analysis.h \
+ tap-sequence-analysis.h \
+ tap-tcp-stream.h \
+ text_import.h \
+ text_import_scanner.h \
+ time_shift.h \
+ traffic_table_ui.h \
+ ui_util.h \
+ util.h \
+ voip_calls.h
# All sources that should be put in the source distribution tarball
libui_a_SOURCES = \
$(WIRESHARK_UI_SRC) \
- $(noinst_HEADERS) \
+ $(WIRESHARK_UI_INCLUDES) \
$(GENERATED_HEADER_FILES) \
$(GENERATED_C_FILES)
-libui_a_DEPENDENCIES =
-
libui_dirty_a_SOURCES = \
$(DIRTY_GENERATED_C_FILES)
libui_dirty_a_CFLAGS = $(GENERATED_CFLAGS)
-libui_dirty_a_DEPENDENCIES =
+EXTRA_DIST = \
+ .editorconfig \
+ $(GENERATOR_FILES) \
+ CMakeLists.txt \
+ doxygen.cfg.in \
+ win32
+
+BUILT_SOURCES = $(GENERATED_HEADER_FILES)
+
+CLEANFILES = \
+ doxygen-ui.tag \
+ libui.a \
+ libui_dirty.a \
+ *~
+
+MAINTAINERCLEANFILES = \
+ $(GENERATED_FILES) \
+ Makefile.in
+
+text_import_scanner_lex.h: text_import_scanner.c
doxygen:
if HAVE_DOXYGEN
@@ -79,11 +194,3 @@ checkapi-todo:
$(PERL) $(top_srcdir)/tools/checkAPIs.pl -M -g deprecated-gtk-todo -build \
-sourcedir=$(srcdir) \
$(WIRESHARK_UI_SRC)
-
-EXTRA_DIST = \
- .editorconfig \
- $(GENERATOR_FILES) \
- CMakeLists.txt \
- doxygen.cfg.in \
- Makefile.common \
- win32